Browse Source

switch to debian based powershell image

this matches the version used on our hosts
-preview is used because buster (including the newer nf_tables backend for iptables) isn't available in stretch
master
lub 2 years ago
parent
commit
9873aec3d0
1 changed files with 2 additions and 1 deletions
  1. +2
    -1
      Dockerfile

+ 2
- 1
Dockerfile View File

@ -1,4 +1,4 @@
FROM mcr.microsoft.com/powershell:latest
FROM mcr.microsoft.com/powershell:preview-debian-buster-slim
VOLUME /stacks
@ -7,6 +7,7 @@ ENV CHAIN="SWARM-NAT" \
WORKDIR /
# install dependencies
RUN pwsh -c 'Set-PSRepository -Name "PSGallery" -InstallationPolicy Trusted' \
&& pwsh -c 'Install-Module powershell-yaml' \
&& apt-get update \


Loading…
Cancel
Save